हिंदी

Write a program in Java to accept a name containing three words and display the surname first, followed by the first and middle names. Sample Input: MOHANDAS KARAMCHAND GANDHISample output: - Computer Applications

Advertisements
Advertisements

प्रश्न

Write a program in Java to accept a name containing three words and display the surname first, followed by the first and middle names.

Sample Input: MOHANDAS KARAMCHAND GANDHI
Sample output: GANDHI MOHANDAS KARAMCHAND 

कोड लेखन

उत्तर

import java.util.*; 
public class SQ4 
{public static void main(String j[]) 
{String s; 
int p = 0; 
Scanner sn = new Scanner(System.in); 
System.out.println("Enter a name"); 
s = ' ' + sn.nextLine(); 
p = s.lastIndexOf(' '); 
System.out.print(s.substring(p + 1)); // from this position till end of the string
System.out.print(s.substring(0, p)); // starting position till p( excluding) 
}} 
shaalaa.com
  क्या इस प्रश्न या उत्तर में कोई त्रुटि है?
अध्याय 4: String Handling - EXERCISES [पृष्ठ २९०]

APPEARS IN

अविचल Computer Applications [English] Class 10 ICSE
अध्याय 4 String Handling
EXERCISES | Q IX. 4. | पृष्ठ २९०
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×