Advertisements
Advertisements
प्रश्न
Write a program in Java to accept a string in lower case and change the first letter of every word to upper case. Display the new string.
Sample input: we are in a cyber world
Sample output: We Are In Cyber World
उत्तर
import java.io.*;
import java.util.Scanner;
class ChangeLetter {
public static void main(String args[ ]) throws IOException {
Scanner sc = new Scanner(System.in);
System.out.print(“Enter String in lowercase:”);
String str 1 = sc.next( );
strl = “” +strl;
String str2 = ” “:
for (int i = 0; i<strl.length( ); i+ +) {
if(strl ,charAt(i) = = “) {
str2 = str2 + ” +Character. toUpperCase(strl.charAt(i+l));
i+ + ;
}.
else
str2= str2 + strl.charAt(i);
}
System.out.println(str2.trim( ));
}
}
APPEARS IN
संबंधित प्रश्न
Write a difference between unary and binary operator.
What is meant by a package?
Name the operators listed below are
(i) <
(ii) + +
(iii) &&
(iv) ? :
Write one difference between / and % operator.
State the difference between == operator and equals () method.
Rewrite the following using ternary operator:
if (x%2 == o)
System.out.print(“EVEN”);
else
System.out.print(“ODD”);
Write a program to input and store roll numbers, names and marks in 3 subjects of n number students in five single dimensional array and display the remark based on average marks as given below : (The maximum marks in the subject are 100).
Average marks = `"Total marks"/3`
Average marks | Remark |
85 - 100 | Excellent |
75 - 84 | Distinction |
60 - 74 | First-class |
40 - 59 | Pass |
Less than 40 | Poor |
Name the primitive data type in Java that is :
A single 16-bit Unicode character whose default value is ‘\u0000’.
Write the Java expression for (a + b)x.
Evaluate the expression when the value of x = 4;
x* = - - x + x + + + x