Advertisements
Advertisements
प्रश्न
Write a program in Java to accept a word. Pass it to a method Magic(String str). The method checks the String for the presence of consecutive letters. If two letters are consecutive at any position then the method prints "It is a Magic String", otherwise it prints "It is not a Magic String".
Sample Input: computer
Sample Output: It is not a Magic String
Sample Input: DELHI
Sample Output: It is a Magic String
कोड लेखन
उत्तर
import java.util.*;
public class FQ8
{
void magic(String x)
{ int i, cnt = 0;
x = x.toUpperCase();
for (i = 0; i < x.length() - 1; i++)
{ if (x.charAt(i) == x.charAt(i + 1))
cnt++;
}
if (cnt > 0)System.out.println("It is a magic string");
else System.out.println("It is not a magic string");
}
public static void main(String j[])
{ FQ8 F = new FQ8();
Scanner ob = new Scanner(System.in);
System.out.println("Enter the String containing double letter sequence(s)");
String s = ob.nextLine();
F.magic(s); // Method call
}}
shaalaa.com
क्या इस प्रश्न या उत्तर में कोई त्रुटि है?