हिंदी

Write a program to enter a two digit number and find out its first factor excluding 1 (one). The program then find the second factor (when the number is divided by the first factor) - Computer Applications

Advertisements
Advertisements

प्रश्न

Write a program to enter a two digit number and find out its first factor excluding 1 (one). The program then find the second factor (when the number is divided by the first factor) and finally displays both the factors. Hint: Use a non-return type method as void fact(int n) to accept the number. 

Sample Input: 21
The first factor of 21 is 3
Sample Output: 3, 7
Sample Input: 30
The first factor of 30 is 2
Sample Output: 2, 15 

कोड लेखन

उत्तर

import java.util.*; 
public class FQ4 
{ 
void fact(int num) 
{
int i, x;
for (i = 2; i <= (num / 2); i++)
{if (num % i == 0)
break;
}
x = num / i;
System.out.println("The first factor is (excluding 1)is " + i);
System.out.println("The second factor i.e. number divided by the first factor " + x);
}

public static void main(String args[])
{FQ4 obj = new FQ4();
Scanner in = new Scanner(System.in);
int n;
System.out.println("Enter the number");
n = in.nextInt();
obj.fact(n);
}}
shaalaa.com
  क्या इस प्रश्न या उत्तर में कोई त्रुटि है?
अध्याय 5: User - Defined Methods - EXERCISES [पृष्ठ ३३८]

APPEARS IN

अविचल Computer Applications [English] Class 10 ICSE
अध्याय 5 User - Defined Methods
EXERCISES | Q VII. 4. | पृष्ठ ३३८
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×