हिंदी

Write a program to generate a triangle or an inverted choice. triangle based upon User's choice. Example 1:Input: Type 1 for a triangle and Type 2 for an inverted triangle Enter your choice 1 - Computer Applications

Advertisements
Advertisements

प्रश्न

Write a program to generate a triangle or an inverted choice. triangle based upon User's choice.

Example 1: Example 2:
Input: Type 1 for a triangle and Type 2 for an inverted triangle Enter your choice 1 Enter a word: BLUEJ Input: Type 1 for a triangle and Type 2 for an inverted triangle Enter your choice 2 Enter a word: BLUEJ

Sample Output: 


L  L
U U U 
E  E  E  E
J  J  J  J  J 

Sample Output: 

B L U E J
B L U E
B L U 
B L 
B

कोड लेखन

उत्तर

import java.util.*;
public class SQ23
{ public static void main(String args[])
{Scanner ob = new Scanner(System.in);
int i, j, n, len;
String s;

System.out.println("****Menu Driven Program****");
System.out.println("Enter your choice");
System.out.println("1. for Triangle / 2. for Inverted Triangle");
n = ob.nextInt();

System.out.println("Enter the word");
s = ob.next();
len = s.length();

switch(n)
{case 1: System.out.println("\n***Pattern1 Triangle***");
         for (i = 0; i < len; i++)
         {for (j = 0; j <= i; j++)
         System.out.print(s.charAt(i));
         System.out.println();
         }
         break;
case 2: System.out.println("\n***Pattern2 Inverted Triangle***"); 
        for (i = len; i > 0; i--) 
        {for (j = 0; j < i; j++) 
        System.out.print(" " + s.charAt(j)); // inner Loop statement 
        System.out.println(); // outer loop statement 
        }
        break; 

default: System.out.println("\n Invalid choice.Please enter a valid choice");
break;
}}}
shaalaa.com
  क्या इस प्रश्न या उत्तर में कोई त्रुटि है?
अध्याय 4: String Handling - EXERCISES [पृष्ठ २९२]

APPEARS IN

अविचल Computer Applications [English] Class 10 ICSE
अध्याय 4 String Handling
EXERCISES | Q IX. 23. | पृष्ठ २९२
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×