हिंदी

Write a program to generate a triangle or an inverted triangle till n terms based upon the user's choice. Example 1:Input: Type 1 for a triangle and Type 2 for an inverted triangle Enter your choice - Computer Applications

Advertisements
Advertisements

प्रश्न

Write a program to generate a triangle or an inverted triangle till n terms based upon the user's choice. 

Example 1: Example 2:

Input: Type 1 for a triangle and Type 2 for an inverted triangle Enter your choice 1
Enter the number of terms 5

Input: Type 1 for a triangle and Type 2 for an inverted triangle Enter your choice 2
Enter the number of terms 6

Sample Output:

1
2     2
3     3     3
4     4     4     4   
5     5     5     5     5 

Sample Output:

6     6     6     6     6     6
5     5     5     5     5    
4     4     4     4    
3     3     3
2     2   

संक्षेप में उत्तर

उत्तर

import java.util.*;
public class Q10
{ public static void main(String az[])
{int n, i, j, x;
Scanner sn = new Scanner(System.in);
System.out.printin("*****MENU****");
System.out.println("1. Pattern - Triangle ");
System.out.println("2. Pattern - Inverted Triangle ");
System.out.printIn("Enter your choice 1 (or) 2");
x = sn.nextInt();
switch(x)
{
case 1: System.out.printIn("Enter the number of terms");
        n = sn.nextInt();
        for (i = 1; i <= n; i++)
{ System.out.println();
        for (j = 1; j <= i; j++)
System.out.print(i);
        }
        break;

case 2: System.out.printIn("Enter the number of terms");
        n = sn.nextInt();
        for (i = n: i >= 1; i--)
{ System.out.println();
        for (j = i; j >= 1; j--)
System.out.print(i);
        }
        break;

default: System.out.println("Invalid Entry");
}
}}
shaalaa.com
  क्या इस प्रश्न या उत्तर में कोई त्रुटि है?
अध्याय 1.1: Nested Loop - EXERCISES [पृष्ठ १४७]

APPEARS IN

अविचल Computer Applications [English] Class 10 ICSE
अध्याय 1.1 Nested Loop
EXERCISES | Q VI. 10. | पृष्ठ १४७
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×