हिंदी

Write a program to input a number and display it into its Binary equivalent. Sample Input: (21)10 Sample Output: (10101)2 - Computer Applications

Advertisements
Advertisements

प्रश्न

Write a program to input a number and display it into its Binary equivalent. 

Sample Input: (21)10

Sample Output: (10101)

संक्षेप में उत्तर

उत्तर

import java.util.*;
public class Q10
{
     public static void main(String args[]) {
         Scanner in = new Scanner(System.in);
         System.out.print(“Enter the decimal number: ");
         long decimal = in.nextLong();
         long binary = 0, m = 1, rem = 0;

         while(decimal > 0) {
           rem = decimal % 2;
           binary = binary + (rem * m);
           m *= 10;
           decimal /= 2;
         }
         System.out.printIn(“Equivalent binary number: " + binary);
     }
}
shaalaa.com
  क्या इस प्रश्न या उत्तर में कोई त्रुटि है?
अध्याय 1.09: Iterative Constructs in Java - EXERCISES [पृष्ठ १२५]

APPEARS IN

अविचल Computer Applications [English] Class 10 ICSE
अध्याय 1.09 Iterative Constructs in Java
EXERCISES | Q VI. 10. | पृष्ठ १२५
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×