Advertisements
Advertisements
प्रश्न
Write a program to input a three digit number. Use a method int Armstrong(int n) to accept the number. The method returns 1, if the number is Armstrong, otherwise zero(0).
Sample Input: 153
Sample Output: 153 = 13 + 53 + 33 = 153
It is an Armstrong Number.
कोड लेखन
उत्तर
import java.util.*;
public class FQ2{
int Armstrong(int n) // FUNCTION DEFINITION
{int d, sum = 0, num = n;
do{
d = n % 10;
sum += (d * d * d); // sum = sum + cube of the number
n = n / 10;
}while (n > 0);
if (num == sum) return 1;
else return 0;
}
public static void main(String h[])
{FQ2 F= new FQ2();
Scanner S = new Scanner(System.in);
int p, m;
System.out.println("Enter the number"); //INPUT
p = S.nextInt();
m = F.Armstrong(p); // METHOD CALL.. returned value stored in m
if (m == 1)
System.out.println("It is an Armstrong number");
else
System.out.println("It is not an Armstrong number");
}}
shaalaa.com
क्या इस प्रश्न या उत्तर में कोई त्रुटि है?