मराठी

A prime number is said to be Twisted Prime, if the new number obtained after reversing the digits is also a prime number. Write a program to accept a number - Computer Applications

Advertisements
Advertisements

प्रश्न

A prime number is said to be Twisted Prime, if the new number obtained after reversing the digits is also a prime number. Write a program to accept a number and check whether the number is Twisted Prime or not.

Sample Input: 167
Sample Output: 761
167 is a Twisted Prime.

थोडक्यात उत्तर

उत्तर

import java.util.*;
public class Q7 {
static booleancheckPrime(int n) // MTD TO CHK WHETHER PRIME
{ int cnt = 0;
for (int i = 1; i <= n; i++)
{ if (n % i == 0)
cnt++; 
}
if (cnt == 2) return true;
else return false;
}
public static void main(String args[]) // MAIN MTD
{int num, d, rev = 0;
Scanner obj = new Scanner(System.in);
System.out.printIn("Enter a prime number");
num = obj.nextInt();
if (checkPrime(num) == true)
{ do{
d = num % 10;
rev = (rev * 10) + d;
num = num / 10; ’
}while (num > 0);
}
if (checkPrime(rev) == true) System.out.printn("It is a twisted prime");
else System.out.printin("Not a twisted prime number");
}}
shaalaa.com
  या प्रश्नात किंवा उत्तरात काही त्रुटी आहे का?
पाठ 1.09: Iterative Constructs in Java - EXERCISES [पृष्ठ १२५]

APPEARS IN

अविचल Computer Applications [English] Class 10 ICSE
पाठ 1.09 Iterative Constructs in Java
EXERCISES | Q VI. 7. | पृष्ठ १२५
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×