मराठी

Using the switch case statement, write a menu driven program for the following: a. To input a number and display only those factors of the numbers which are prime. Sample Input: 84 - Computer Applications

Advertisements
Advertisements

प्रश्न

Using the switch case statement, write a menu driven program for the following:

  1. To input a number and display only those factors of the numbers which are prime.
    Sample Input: 84
    Sample Output: 2, 3, 7
  2. A program that displays the multiplication table from 1 to 10, as shown: 
    1 2 3 4 5 6 7 8 9 10
    2 4 6 8 10 12 14 16 18 20
    3 6 9 12 15 18 21 24 27 30
    .....................................................
    .....................................................
    .....................................................
    9 18 27 36 45 54 63 72 81 90
    10 20 30 40 50 60 70 80 90 100
थोडक्यात उत्तर

उत्तर

import java.util.Scanner;
public class Q12
{
        public static void main(String args[]) {
          Scanner in = new Scanner(System.in);
          System.out.println(“Enter 1 for prime factors”);
          System.out.println(“Enter 2 for multiplication tables”);
          System.out.print(“Enter your choice: ©);
          int ch = in.nextInt();
          switch (ch) {
            case 1:
              System.out.print(“Enter a number: );
              int num = in.nextInt();
                for (int i = 2; i <= num / 2; i++) {
                   int c = 0;
                   if (num % i == 0) {
                      for (int j = 1; <= i; j++) {
                        if (i % j == 0)
                          c++;
                      }
                      if (c == 2)
                          System.out.print(i + “ ");
                   }
             }
             break;
            case 2:
               for (int i = 1; i <= 10; i++) {
                  for (int j = 1; j <= 10; j++)
                       System.out.print((i * j) +“ “);
                  System.out.println();
               }
               break;

            default:
                System.out.printIn(“Incorrect Choice”);
         }
    }
}
shaalaa.com
  या प्रश्नात किंवा उत्तरात काही त्रुटी आहे का?
पाठ 1.1: Nested Loop - EXERCISES [पृष्ठ १४७]

APPEARS IN

अविचल Computer Applications [English] Class 10 ICSE
पाठ 1.1 Nested Loop
EXERCISES | Q VI. 12. | पृष्ठ १४७
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×