Advertisements
Advertisements
प्रश्न
Write a program in Java to enter a number containing three digits or more. Arrange the digits of the entered number in ascending order and display the result.
Sample Input: Enter a number 4972
Sample Output: 2, 4, 7, 9
थोडक्यात उत्तर
उत्तर
import java.util.*;
public class Q6
{ public static void main(String args[])
{ Scanner in = new Scanner(System.in);
int num, n, d;
String s = "";
System.out.println("Enter a number with 3 or more digits");
num = in.nextInt();
for (int i = 9; i >= 0; i--)
{ n = num;
do{
d = n % 10;
if (d == i)
{s = d + "," + s;
}
n = n / 10;
} while (n > 0);
}
System.out.printIn(s);
}}
shaalaa.com
या प्रश्नात किंवा उत्तरात काही त्रुटी आहे का?