मराठी

Write a program in Java to store 20 different names and telephone numbers of your friends in two different Single Dimensional Arrays (SDA). Now arrange all the names in alphabetical order - Computer Applications

Advertisements
Advertisements

प्रश्न

Write a program in Java to store 20 different names and telephone numbers of your friends in two different Single Dimensional Arrays (SDA). Now arrange all the names in alphabetical order and display all the names along with their respective telephone numbers use selection sort technique.

Write a program to accept 10 names in a Single Dimensional Array (SDA). Display the names whose first letter matches with the letter entered by the user.

Sample Input: Aman Shahi
Akash Gupta
Suman Mishra and so on --------
Sample Output: Enter a letter
                            A
                            Aman Shahi
                            Akash Gupta
                            --------------

कोड लेखन

उत्तर

  1. import java.util.*;
    public class SQ26_A
    {public static void main(String args[]){
    Scanner ob = new Scanner(System.in);
    String tmp, n[] = new String[20];
    long t, ph[] = new long[20];
    int i, j;
     
    
    INPUT LOOP FOR NAME & PHONE
    for (i = 0; i < n.length; i++)
    {
    System.out.print("Name: ");
    n[i] = ob.next();
    System.out.print("Phone num: ");
    ph[i] = ob.nextLong();
    }
    
    //LOOP TO SORT NAMES IN ALPHABETICAL ORDER
    int min;
    for (i = 0; i < n.length - 1; i++)
    {
       min = i;
       for (j = i + 1; j < n.length; j++)
       { if (n[j].compareTo(n[min]) < 0)
       min = j;
       }
    
       tmp = n[i];
       n[i] = n[min];
       n[min] = tmp;
    
       t = ph[i];
       ph[i] = ph[min];
       ph[min] = t;
    }
    System.out.println("\n TELEPHONE DIRECTORY");
    for (j = 0; j < n.length; j++)
    System.out.println(n[j] + "\t\t" + ph[j]);
    }}
  2. import java.util.*;
    public class SQ26_B
    {public static void main(String args[]){
    Scanner ob = new Scanner(System.in);
    String n[] = new String[10];
    char ch;
    int i;
    
    // INPUT LOOP FOR NAME
    for (i = 0; i < n.length; i++)
    {System.out.print("Name: ");
    n[i] = ob.next();
    }
    
    // INPUT OF ALPHABET
    System.out.println("Enter the letter to be searched");
    ch = ob.next().charAt(0);
    
    // INPUT OF ALPHABET
    System.out.println("Enter the letter to be searched");
    ch = ob.next().charAt(0);
    
    // OUTPUT LOOP - NAMES MATCHING WITH THE ALPHABET
    for (i = 0; i < n.length; i++)
    {
    if (ch == n[i].charAt(0))
    System.out.println(n[i]);
    }}}
shaalaa.com
  या प्रश्नात किंवा उत्तरात काही त्रुटी आहे का?
पाठ 4: String Handling - EXERCISES [पृष्ठ २९३]

APPEARS IN

अविचल Computer Applications [English] Class 10 ICSE
पाठ 4 String Handling
EXERCISES | Q IX. 26. | पृष्ठ २९३
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×