Advertisements
Advertisements
प्रश्न
Write a program to input two characters from the keyboard. Find the difference (d) between their ASCII codes. Display the following messages:
If d = 0: both the characters are same.
If d < 0: first character is smaller.
If d > 0: second character is smaller.
Sample Input: D
P
Sample Output: d = (68 − 80) = −12
First character is smaller
थोडक्यात उत्तर
उत्तर
import java.util.*;
public class Q6
{ public static void main(String args[])
{ Scanner in = new Scanner(System.in);
char ch1, ch2;
int d;
System.out.println("Enter the two characters");
ch1 = in.next().charAt(0);
ch2 = in.next().charAt(0);
d = (ch1 − ch2);
if (d == 0)
System.out.println("Both the characters are the same");
else if (d > 0)
System.out.println("The second character is smaller");
else if (d < 0)
System.out.println("The first character is smaller");
}}
shaalaa.com
या प्रश्नात किंवा उत्तरात काही त्रुटी आहे का?
पाठ 2: Library Classes - EXERCISES [पृष्ठ १७९]