English

A number is said to be Multiple Harshad number, when divided by the sum of its digits, produces another Harshad Number. Write a program to input a number - Computer Applications

Advertisements
Advertisements

Question

A number is said to be Multiple Harshad number, when divided by the sum of its digits, produces another Harshad Number. Write a program to input a number and check whether it is a Multiple Harshad Number or not. 

(When a number is divisible by the sum of its digit, it is called Harshad Number).

Sample Input: 6804
Hint: 6804 ⇒ 6+8+0+4 = 18 ⇒ 6804/18 = 378
          378 ⇒ 3+7+8= 18 ⇒ 378/18 = 21
          21 ⇒ 2+1 = 3 ⇒ 21/3 = 7

Sample Output: Multiple Harshad Number 

Answer in Brief

Solution

import java.util.*;
public class Q8
{public static void main(String args[])
{ int n, p, d, sum = 0, cnt = 0;
Scanner obj = new Scanner(System.in);
System.out.println("***Multiple Harshad Number***");
System.out.printin("Enter the number");
n = obj.nextInt();
do
{
p = n; // store the original number in 'p' before altering n
sum = 0; // clear sum for every new value of n (ie) p
do{
d = n % 10; 
sum += d; // accumulate the sum of the digits in sum
n = n / 10; 
} while (n > 0); 
if (p % sum == 0) 
{n = p / sum; // The quotient is used for the next iteration 
cnt++; // ent = 1 implies HARSHAD/NIVEN ...cnt > 1 multiple harshad 
} 
System.out.println(n); //OPTIONAL PRINT 
} while (n > 9); 

if (cnt > 1) System.out.println("It is a Multiple Harshad Number"); 
else System.out.printIn("It is a not a Multiple Harshad Number"); 
}}
shaalaa.com
  Is there an error in this question or solution?
Chapter 1.1: Nested Loop - EXERCISES [Page 146]

APPEARS IN

Avichal Computer Applications [English] Class 10 ICSE
Chapter 1.1 Nested Loop
EXERCISES | Q VI. 8. | Page 146
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×