English

Write a Program to Input a Sentence and Convert It into Uppercase and Count and Display the Total Number of Words Starting with a Letter ‘A’. - Computer Applications

Advertisements
Advertisements

Question

Write a program to input a sentence and convert it into uppercase and count and display the total number of words starting with a letter ‘A’.

Example:
Sample Input: ADVANCEMENT AND APPLICATION OF INFORMATION TECHNOLOGY ARE EVER CHANGING.
Sample Output: Total number of words starting with letter A’ = 4.

Answer in Brief

Solution

import java.io.*;
import java.util.*;
class UpperCount {
public static void main(String args[ ]) {
int i, a;
Scanner sc = new Scanner(System.in);
String str, str1, str2;
System.out.prindn(“Enter sentence::”);
str = sc.nextLine();
strl = str.toUpperCaseO; ‘
str2 = “” + strl;
a = 0; ,
for (i = 0; i < = str2.1ength(); i+ +) {
if(str2.charAt(i) == ‘ ‘)
if(str2.charAt(i + 1) == ‘A’);
a+ +;
}
System.out.println(“Total number of words starting with letter ‘A’::” +a);
}
}

shaalaa.com
  Is there an error in this question or solution?
2018-2019 (March) Set 1

RELATED QUESTIONS

Write the output for the following :

String s1 = “phoenix”; String s2 =”island”;

System.out.prindn (s1.substring(0).concat (s2.substring(2)));

System.out.println(s2.toUpperCase( ));


String x[] = {“SAMSUNG”, “NOKIA”, “SONY”, “MICROMAX”, “BLACKBERRY”};

Give the output of the following statements:

  1. System.out.println(x[1]);
  2. System.out.println(x[3].length()); 

Write the output for the following :

String s= “Today is Test”;
System.out.println(s.indexOf(‘T’)); System.out.println(s.substring(0, 7) + ” ” + “Holiday”);


What is the function of catch block in exception handling? Where does it appear in a program?


State the output when the following program segment is executed:

String a = "Smartphone", b = "Graphic Art"; 
String h = a.substring(2, 5); 
String k = b.substring(S).toUpperCase(); 
System.out.println(h); 
System.out.println(k.equalsignoreCase(h)); 

Write the output for the following :

System.out.printIn(“Incredible” + “\n” + “world”);


Design a class to overload a function Joystring( )as follows:

(i) void Joystring (String s, char ch1 char ch2) with one string argument and two character arguments that replaces the character argument ch1 with the character argument ch2 in the given string s and prints the new string.
Example:
Input value of s = “TECHNALAGY”
ch1=‘A’,
ch2=‘O’
Output: TECHNOLOGY
(ii) void Joystring (String s) with one string argument that prints the position of the first space and the last space of the given string s.
Example:
Input value of = “Cloud computing means Internet based computing”
Output: First index: 5
Last index: 36
(iii) void Joystring (String s1, String s2) with two string arguments that combines the two string with a space between them and prints the resultant string. Example :
Input value of s1 =“COMMON WEALTH”
Input value of s2 =“GAMES”
Output: COMMON WEALTH GAMES
(use library functions)


State the output of the following program segment:
String str1 = “great”; String str2 = “minds”;
System.out.println (str1.substring (0,2).concat(str2.substring (1)));
System.out.println ((“WH”+(str1.substring (2).toUpperCase())));


Rewrite the following program segment using if-else statements instead of the ternary operator: 
String grade = (mark >= 90) ? “A” : (mark >= 80) ? “B” : “C”;


State the value of characteristic and mantissa when the following code is executed:
String s = “4.3756”;
int n = s.indexOf(‘.’);
int characteristic=Integer.parseInt (s.substring (0,n));
int mantissa=Integer.valueOf(s.substring(n+1)); 


Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×