Advertisements
Advertisements
Question
Write a program to input a sentence and display the word of the sentence that contains maximum number of vowels.
Sample Input: HAPPY NEW YEAR
Sample Output: The word with maximum number of vowels: YEAR
Code Writing
Solution
// Program to find the word which has the max. no. of vowels
import java.util.*;
public class SQ11
{public static void main(String t[]){
String s = "", tmp = "", word = "";
int max = 0, cnt = 0;
char ch;
System.out.println("Enter the String");
Scanner sn = new Scanner(System.in);
s = sn.nextLine().toLowerCase();
s = st + " " // add a single space at the end of the string
for (int i = 0; i < s.length(); i++)
{
if (s.charAt(i) != ' ')
{ch = s.charAt(i);
tmp += ch;
if (ch = 'a' || ch == 'e' || ch == 'i' || ch == 'o' || ch == 'u')
cnt++;
}
else
{if (cnt >= max)
{max = cnt;
word = tmp;
}
cnt = 0; // reset cnt and tmp for the next word
tmp = "";
}
}
System.out.println("The word with the maximum vowels is: " + word);
}}
shaalaa.com
Is there an error in this question or solution?