Advertisements
Advertisements
Question
Write a program to input a sentence. Convert the sentence into uppercase letters. Display the words along with frequency of the words which have at least a pair of consecutive letters.
Sample Input: MODEM IS AN ELECTRONIC DEVICE
Sample Output:
MODEM
DEVICE
Number of words containing consecutive letters: 2
Code Writing
Solution
import java.util.*;
public class SQ19
{ public static void main(String a[])
{
int i = 0, flag = 0;
String s, tmp = "";
System.out.println("Enter the string");
Scanner sn = new Scanner(System.in);
s = sn.nextLine().toUpperCase();
s = s + " ";
while (i <= s.length() − 1) // from 0 till the character before the last position
{
if (s.charAt(i) != ' ')
{tmp = tmp + s.charAt(i);
if (s.charAt(i + 1) − s.charAt(i) == 1)
flag = 1;
}
else
{if (flag == 1)
System.out.println(tmp);
tmp = ""; flag = 0; // clear tmp and flag
}
i++; // loop variable
}
}}
shaalaa.com
Is there an error in this question or solution?