English

Write a program to input a sentence. Create a new sentence by replacing each consonant with the previous letter. If the previous letter is a vowel then replace it with the next letter - Computer Applications

Advertisements
Advertisements

Question

Write a program to input a sentence. Create a new sentence by replacing each consonant with the previous letter. If the previous letter is a vowel then replace it with the next letter (i.e., if the letter is B then replace it with C as the previous letter of B is A). Other characters must remain same. Display the new sentence.

Sample Input: ICC WORLD CUP
Sample Output: IBB VOQKC BUQ 

Code Writing

Solution

import java.util.Scanner;

public class SQ14
{
    public static void main(String args[]) {
        Scanner in = new Scanner(System.in);
        
        System.out.println("Enter a sentence: ");
        String str = in.nextLine();      
        
        int len = str.length();
        
        String newStr = "";
                
        for (int i = 0; i < len; i++) {
            char ch = str.charAt(i);
            char chUp = Character.toUpperCase(ch);
            if (chUp == 'A' 
                || chUp == 'E' 
                || chUp == 'I' 
                || chUp == 'O' 
                || chUp == 'U') {
                newStr = newStr + ch;
            }
            else {
                char prevChar = (char)(ch − 1);
                char prevCharUp = Character.toUpperCase(prevChar);
                if (prevCharUp == 'A' 
                    || prevCharUp == 'E' 
                    || prevCharUp == 'I' 
                    || prevCharUp == 'O' 
                    || prevCharUp == 'U') {
                    newStr = newStr + (char)(ch + 1);
                }
                else {
                    newStr = newStr + prevChar;
                }
            }
        }     
        System.out.println(newStr);
    }
}
shaalaa.com
  Is there an error in this question or solution?
Chapter 4: String Handling - EXERCISES [Page 291]

APPEARS IN

Avichal Computer Applications [English] Class 10 ICSE
Chapter 4 String Handling
EXERCISES | Q IX. 14. | Page 291
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×