Advertisements
Advertisements
प्रश्न
A 'Happy Word' is defined as:
Take a word and calculate the word's value based on position of the letters in English alphabet. On the basis of word's value, find the sum of the squares of its digits. Repeat the process with the resultant number until the number equals 1 (one). If the number ends with 1 then the word is called a 'Happy Word'. Write a program to input a word and check whether it a 'Happy Word' or not. The program displays a message accordingly.
Sample Input: VAT
Place value of V = 22, A = 1, T = 20
[Hint: A = 1, B = 2, ---------------------------, Z = 26]
Solution: 22120 ⇒ 22 + 22 + 12 + 22 + 02 = 13 ⇒ 12 + 32 = 10 ⇒ 12 + 02 = 1
Sample Output: A Happy Word
कोड लेखन
उत्तर
import java.util.*;
public class SQ15
{ public static void main(String k[]){
char ch;
int sum = 0, d = 0, val = 0, n;
String tmp = "";
System.out.println("Enter the string");
Scanner scn = new Scanner(System.in);
String str = scn.next().toUpperCase();
for (int i = 0; i < str.length(); i++)
{ch = str.charAt(i);
val = ch - 64; // Ascii val of A = 65, but assigned must be A = 1, B = 2, C = 3, D = 4....
tmp = tmp + val;
}
n = Integer.valueOf(tmp); // integer value of temp is assigned to n
do
{sum = 0;
do
{
d = n % 10; // stores the remainder after division by 10
sum = sum + d * d; // square of the digit is stored in swum
n = n / 10; // stores the quotient
}while (n > 0);
n = sum;
}while (sum >= 10);
if (sum == 1)System.out.println("It is a happy word");
else System.out.println("It is not a happy word");
}}
shaalaa.com
क्या इस प्रश्न या उत्तर में कोई त्रुटि है?