Advertisements
Advertisements
प्रश्न
Write a program to input a sentence. Count and display the frequency of each letter of the sentence in alphabetical order.
Sample Input: COMPUTER APPLICATIONS
Sample Output:
Character | Frequency | Character | Frequency |
A | 2 | O | 2 |
C | 2 | P | 3 |
I | 1 | R | 1 |
L | 2 | S | 1 |
M | 1 | T | 2 |
N | 1 | U | 1 |
कोड लेखन
उत्तर
/*Program to print the frequency of each letter, in alphabetical order*/
import java.util.*;
public class SQ16_versionB
{ public static void main(String y[])
{
int i, j, cnt = 0;
char ch = "";
System.out.println("Enter a string");
Scanner scn = new Scanner(System.in);
String s = scn.nextLine();
s = s.toUpperCase();
s = s.replace(" ",""); // delete spaces
System.out.println("Letter \t Frequency");
for (i = 65; i <= 90; i++) // ascii value of A to Z
{ for (j = 0; j < s.length(); j++)
{ch = s.charAt(j); // extract char at jth position
if (i == ch) // i has the ascii value of the alphabet
cnt++;
}
if (cnt > 0)
System.out.println((char)i + "\t" + cnt);
cnt = 0; // clear cnt outside if-block
}}}
/*Program to print the frequency of each letter, in the order in which it is present in the String*/
import java.util.*;
public class SQ16_versionA
{ public static void main(String args[])
{
int i, cnt; char ch;
Scanner snn = new Scanner(System.in);
System.out.println("Enter the String");
String str = snn.nextLine();
str = str.replace(" ", "");
do
{
cnt = 1;
ch = str.charAt(0); // First character
for (i = 1; i < str.length(); i++) // from second till the last character
{if (ch == str.charAt(i)) // for repeated character,increment count
cnt++;
}
System.out.println(ch + "\t" + cnt);
str = str.replace(str.charAt(0),' '); // FOR DELETING THE FIRST CHAR
str = str.replace(" ", "");
}while (str.length() > 0);
}}
shaalaa.com
क्या इस प्रश्न या उत्तर में कोई त्रुटि है?