Advertisements
Advertisements
प्रश्न
Write a program in Java to accept a String from the user. Pass the String to a method Change (String str) which displays the first character of each word after changing the case (lower to upper and vice versa).
Sample Input: Delhi public school
Sample Output: d
P
S
कोड लेखन
उत्तर
import java.util.*;
public class FQ11{
static void First(String s)
{char ch, ch1;
s = ' ' + s; // add space in the beginning
for (int i = 0; i < s.length(); i++)
{ ch = s.charAt(i);
if (ch == ' ') // if ch == space
{ch1 = s.charAt(i + 1);
if (Character.isUpperCase(ch1) == true)
System.out.println(Character.toLowerCase(ch1));
else
System.out.println(Character.toUpperCase(ch1));
}}
public static void main(String j[])
{Scanner sn = new Scanner(System.in);
System.out.println("Enter a string");
First(sn.nextLine());
}}
shaalaa.com
क्या इस प्रश्न या उत्तर में कोई त्रुटि है?
अध्याय 5: User - Defined Methods - EXERCISES [पृष्ठ ३३९]