Advertisements
Advertisements
प्रश्न
Write a program in Java to accept a String from the user. Pass the String to a method Display (String str) which displays the consonants present in the String.
Sample Input: computer
Sample Output: c
m
p
t
r
कोड लेखन
उत्तर
import java.util.*;
public class FQ10{
static void Display(String str)
{ char ch;
str = str.toLowerCase();
for (int i = 0; i < str.length(); i++)
{ ch = str.charAt(i);
if (ch == "a" || ch == "e" || ch == "i" || ch == "o" || ch == "u")
continue;
else
System.out.println(ch);
}}
public static void main(String j[])
{Scanner sn = new Scanner(System.in);
System.out.println("Enter a string");
Display(sn.nextLine()); // Pass the Input as the argument to the method
}}
shaalaa.com
क्या इस प्रश्न या उत्तर में कोई त्रुटि है?
अध्याय 5: User - Defined Methods - EXERCISES [पृष्ठ ३३८]