English

Write a program in Java to accept a String from the user. Pass the String to a method Display (String str) which displays the consonants present in the String. Sample Input: computerSample - Computer Applications

Advertisements
Advertisements

Question

Write a program in Java to accept a String from the user. Pass the String to a method Display (String str) which displays the consonants present in the String. 

Sample Input: computer
Sample Output: c
                            m
                            p
                            t
                            r

Code Writing

Solution

import java.util.*;
public class FQ10{
static void Display(String str)
{ char ch;
str = str.toLowerCase();
for (int i = 0; i < str.length(); i++)
{ ch = str.charAt(i);
if (ch == "a" || ch == "e" || ch == "i" || ch == "o" || ch == "u")
continue;
else
System.out.println(ch);
}}

public static void main(String j[])
{Scanner sn = new Scanner(System.in);
System.out.println("Enter a string");
Display(sn.nextLine()); // Pass the Input as the argument to the method
}}
shaalaa.com
  Is there an error in this question or solution?
Chapter 5: User - Defined Methods - EXERCISES [Page 338]

APPEARS IN

Avichal Computer Applications [English] Class 10 ICSE
Chapter 5 User - Defined Methods
EXERCISES | Q VII. 10. | Page 338
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×