मराठी

Write a program in Java to accept a String from the user. Pass the String to a method Display (String str) which displays the consonants present in the String. Sample Input: computerSample - Computer Applications

Advertisements
Advertisements

प्रश्न

Write a program in Java to accept a String from the user. Pass the String to a method Display (String str) which displays the consonants present in the String. 

Sample Input: computer
Sample Output: c
                            m
                            p
                            t
                            r

कोड लेखन

उत्तर

import java.util.*;
public class FQ10{
static void Display(String str)
{ char ch;
str = str.toLowerCase();
for (int i = 0; i < str.length(); i++)
{ ch = str.charAt(i);
if (ch == "a" || ch == "e" || ch == "i" || ch == "o" || ch == "u")
continue;
else
System.out.println(ch);
}}

public static void main(String j[])
{Scanner sn = new Scanner(System.in);
System.out.println("Enter a string");
Display(sn.nextLine()); // Pass the Input as the argument to the method
}}
shaalaa.com
  या प्रश्नात किंवा उत्तरात काही त्रुटी आहे का?
पाठ 5: User - Defined Methods - EXERCISES [पृष्ठ ३३८]

APPEARS IN

अविचल Computer Applications [English] Class 10 ICSE
पाठ 5 User - Defined Methods
EXERCISES | Q VII. 10. | पृष्ठ ३३८
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×