Advertisements
Advertisements
प्रश्न
Write a program to input a letter. Find its ASCII code. Reverse the ASCII code and display the equivalent character.
Sample Input: Y
Sample Output: ASCII Code = 89
Reverse the code = 98
Equivalent character: b
संक्षेप में उत्तर
उत्तर
import java.util.*;
public class Q9
{ public static void main(String args[])
{ Scanner in = new Scanner(System.in);
char ch;
int n, num = 0, d;
System.out.println("Enter the character");
ch = in.next().charAt(0);
n = (int) ch;
do
{ d = n % 10;
num = num * 10 + d;
n = n / 10;
}
while (n > 0);
System.out.println("ASCII code = " + (int) ch);
System.out.printIn("Reversed code = " + num);
System.out.printin("Equivalent character = " + (char) num);
}}
shaalaa.com
क्या इस प्रश्न या उत्तर में कोई त्रुटि है?
अध्याय 2: Library Classes - EXERCISES [पृष्ठ १७९]