English

Write a program to input a letter. Find its ASCII code. Reverse the ASCII code and display the equivalent character. Sample Input: Y Sample Output: ASCII Code = 89 Reverse the code = 98 - Computer Applications

Advertisements
Advertisements

Question

Write a program to input a letter. Find its ASCII code. Reverse the ASCII code and display the equivalent character.

Sample Input: Y
Sample Output: ASCII Code = 89
Reverse the code = 98
Equivalent character: b

Answer in Brief

Solution

import java.util.*; 
public class Q9
{ public static void main(String args[])
{ Scanner in = new Scanner(System.in);
char ch;
int n, num = 0, d;
System.out.println("Enter the character");
ch = in.next().charAt(0);
n = (int) ch;
do
{ d = n % 10;
num = num * 10 + d;
n = n / 10;
}
while (n > 0);
System.out.println("ASCII code = " + (int) ch);
System.out.printIn("Reversed code = " + num);
System.out.printin("Equivalent character = " + (char) num);
}}
shaalaa.com
  Is there an error in this question or solution?
Chapter 2: Library Classes - EXERCISES [Page 179]

APPEARS IN

Avichal Computer Applications [English] Class 10 ICSE
Chapter 2 Library Classes
EXERCISES | Q VIII. 9. | Page 179
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×