Advertisements
Advertisements
प्रश्न
Write a program to input a number and check whether it is a prime number or not. If it is not a prime number then display the next number that is prime.
Sample Input: 14
Sample Output: 17
संक्षेप में उत्तर
उत्तर
import java.util.*;
public class Q8
{ public static void main(String args[])
{int flag = 1, cnt = 0, n;
Scanner obj = new Scanner(System.in);
System.out.printIn("Enter the number");
n = obj.nextInt();
while (true)
{ System.out.println("n = " + n);
cnt = 0;
for (int i = 1; i <= n; i++)
{ if (n % i == 0)
cnt++;
}
if (cnt == 2)
{System.out.print(n + " is a Prime number");
break;
}
else
n++;
}}}
shaalaa.com
क्या इस प्रश्न या उत्तर में कोई त्रुटि है?