English

Write a program to input a number and check whether it is a prime number or not. If it is not a prime number then display the next number that is prime. Sample Input: 14 Sample Output: 17 - Computer Applications

Advertisements
Advertisements

Question

Write a program to input a number and check whether it is a prime number or not. If it is not a prime number then display the next number that is prime.

Sample Input: 14
Sample Output: 17

Answer in Brief

Solution

import java.util.*;
public class Q8
{ public static void main(String args[])
{int flag = 1, cnt = 0, n;
Scanner obj = new Scanner(System.in);
System.out.printIn("Enter the number");
n = obj.nextInt();
while (true)
{ System.out.println("n = " + n);
cnt = 0;
for (int i = 1; i <= n; i++)
{ if (n % i == 0)
cnt++;
}
if (cnt == 2)
{System.out.print(n + " is a Prime number");
break;
}
else
n++;
}}}
shaalaa.com
  Is there an error in this question or solution?
Chapter 1.09: Iterative Constructs in Java - EXERCISES [Page 125]

APPEARS IN

Avichal Computer Applications [English] Class 10 ICSE
Chapter 1.09 Iterative Constructs in Java
EXERCISES | Q VI. 8. | Page 125
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×