Advertisements
Advertisements
Question
A number is said to be Duck if the digit zero is (0) present in it. Write a program to accept a number and check whether the number is Duck or not.
The program displays the message accordingly. (The number must not begin with zero)
Sample Input: 5063
Sample Output: It is a Duck number.
Sample Input: 7453
Sample Output: It is not a Duck number.
Answer in Brief
Solution
import java.util.*;
public class Q9
{ public static void main(String jj[])
{ int n, d, flag = 0;
Scanner in = new Scanner(System.in);
System.out.printIn("Enter the number ");
n = in.nextInt();
do{
d = n % 10;
if (d == 0)
{flag = 1;
break;
}
else
n = n / 10;
}while (n > 0);
if (flag == 1)
System.out.println("It is a Duck number");
else
System.out.println("It is not a Duck number");
}}
shaalaa.com
Is there an error in this question or solution?