मराठी

Write a program to accept a string. Convert the string into uppercase letters. Count and output the number of double letter sequences that exist in the string. Sample Input - Computer Applications

Advertisements
Advertisements

प्रश्न

Write a program to accept a string. Convert the string into uppercase letters. Count and output the number of double letter sequences that exist in the string. 

Sample Input: "SHE WAS FEEDING THE LITTLE RABBIT WITH AN APPLE"
Sample Output: 4

कोड लेखन

उत्तर

// To count and output the number of double letter sequences in the string
// INPUT: BOOKS ON APPLE TREES —> OUTPUT = 3
import java.util.*;
public class SQ17
{ public static void main(String j[])
{ int i, cnt = 0;
System.out.println("Enter the String");
Scanner sn = new Scanner(System.in);
String s = sn.nextLine();
s = s.toUpperCase();

for (i = 0; i < s.length() − 1; i++)
if (s.charAt(i) == s.charAt(i + 1))
cnt++;

System.out.println("Number of double letter sequence present: " + cnt);
}}
shaalaa.com
  या प्रश्नात किंवा उत्तरात काही त्रुटी आहे का?
पाठ 4: String Handling - EXERCISES [पृष्ठ २९१]

APPEARS IN

अविचल Computer Applications [English] Class 10 ICSE
पाठ 4 String Handling
EXERCISES | Q IX. 17. | पृष्ठ २९१
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×