Advertisements
Advertisements
Question
Write a program to accept a string. Convert the string into uppercase letters. Count and output the number of double letter sequences that exist in the string.
Sample Input: "SHE WAS FEEDING THE LITTLE RABBIT WITH AN APPLE"
Sample Output: 4
Code Writing
Solution
// To count and output the number of double letter sequences in the string
// INPUT: BOOKS ON APPLE TREES —> OUTPUT = 3
import java.util.*;
public class SQ17
{ public static void main(String j[])
{ int i, cnt = 0;
System.out.println("Enter the String");
Scanner sn = new Scanner(System.in);
String s = sn.nextLine();
s = s.toUpperCase();
for (i = 0; i < s.length() − 1; i++)
if (s.charAt(i) == s.charAt(i + 1))
cnt++;
System.out.println("Number of double letter sequence present: " + cnt);
}}
shaalaa.com
Is there an error in this question or solution?