Advertisements
Advertisements
Question
Write a program in Java to accept a name (Containing three words) and Display only the initials (i.e., first letter of each word).
Sample Input: LAL KRISHNA ADVANI
Sample output: L K A
Code Writing
Solution
import java.util.*;
public class SQ3
{public static void main(Stringj[])
{String s, tmp = "";
Scanner sn = new Scanner(System.in);
System.out.println("Enter a name");
s = " " + sn.nextLine().trim();
for (int i = 0; i < s.length(); i++)
{if (s.charAt(i) == ' ')
tmp = tmp + s.charAt(i + 1);
}
System.out.println(tmp);
}}
shaalaa.com
Is there an error in this question or solution?