English

Write a program in Java to enter a sentence. Display the words which are only palindrome. Sample Input: MOM AND DAD ARE NOT AT HOMESample Output: MOM DAD - Computer Applications

Advertisements
Advertisements

Question

Write a program in Java to enter a sentence. Display the words which are only palindrome.

Sample Input: MOM AND DAD ARE NOT AT HOME
Sample Output: MOM
                            DAD

Code Writing

Solution

import java.util.*;
public class SQ9
{public static void main(String args[])
{ String wrd = "", rev = "";
char ch;
Scanner obj = new Scanner(System.in); 
System.out.println("Enter a String");
String s = obj.nextLine();
s = s.toLowerCase() + " "; // Add an extra space at the end
for (int i = 0; i < s.length(); i++)
{ ch = s.charAt(i);
if (ch != ' ')
{wrd += ch; rev = ch + rev;}
else
{if (wrd.equals(rev)) 
System.out.println{wrd);
wrd = ""; rev = "";
}} // end of if-else block and outer for loop
}}
shaalaa.com
  Is there an error in this question or solution?
Chapter 4: String Handling - EXERCISES [Page 290]

APPEARS IN

Avichal Computer Applications [English] Class 10 ICSE
Chapter 4 String Handling
EXERCISES | Q IX. 9. | Page 290
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×