English

Write a program in Java to enter a sentence. Frame a word by joining all the first characters of each word of the sentence. Display the word. Sample Input: Vital Information Resource Under - Computer Applications

Advertisements
Advertisements

Question

Write a program in Java to enter a sentence. Frame a word by joining all the first characters of each word of the sentence. Display the word.

Sample Input: Vital Information Resource Under Seize
Sample Output: VIRUS

Code Writing

Solution

import java.util.*; 
public class SQ8 
170 
{ public static void main(String h[]) 
{ 
String ns = ""; 
System.out.println("Enter the string"); 
Scanner sn = new Scanner(System.in); 
String s = " " + sn.nextLine(); 

for (int j = 0; j < s.length(); j++)
{ if (s.charAt(j) == ' ')
ns += s.charAt(j + 1); // the first letter after space
}

System.out.println(ns); 
}}
shaalaa.com
  Is there an error in this question or solution?
Chapter 4: String Handling - EXERCISES [Page 290]

APPEARS IN

Avichal Computer Applications [English] Class 10 ICSE
Chapter 4 String Handling
EXERCISES | Q IX. 8. | Page 290
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×