Advertisements
Advertisements
Question
Write a program in Java to accept a String in uppercase and replace all the vowels present in the String with Asterisk (*) sign.
Sample Input: "TATA STEEL IS IN JAMSHEDPUR"
Sample output: T*T* ST**L *S *N J*MSH*DP*R
Code Writing
Solution
import java.util.*;
public class SQ7
{ public static void main(String args[])
{ String s;
char ch;
Scanner sn = new Scanner(System.in);
System.out.println("Enter a string in upper case");
s = sn.nextLine();
s = s.toUpperCase();
for (int i = 0; i < s.length(); i++)
{ ch = s.charAt(i);
if (ch == 'A' || ch == 'E' || ch == 'I' || ch == 'O' || ch == 'U')
s = s.replace(ch, '*');
}
System.out.println(s);
}}
shaalaa.com
Is there an error in this question or solution?