English

Write a program in Java to accept a word and display the ASCII code of each character of the word. Sample Input: BLUEJSample output: ASCII of B = 66 ASCII of L = 75 ASCII of U = 84 ASCII of E = 69 - Computer Applications

Advertisements
Advertisements

Question

Write a program in Java to accept a word and display the ASCII code of each character of the word.

Sample Input: BLUEJ
Sample output: ASCII of B = 66
                           ASCII of L = 75
                           ASCII of U = 84
                           ASCII of E = 69
                           ASCII of J = 73

Code Writing

Solution

import java.util.*;
public class SQ6
{ public static void main(String h[])
{ char ch;
System.out.println("Enter a word ");
Scanner x = new Scanner(System.in);
String str = x.next();

for (int i = 0; i < str.length(); i++)
{ ch = str.charAt(i);
  System.out.println("ASCII OF " + ch + " is " + (byte) ch);
}}}
shaalaa.com
  Is there an error in this question or solution?
Chapter 4: String Handling - EXERCISES [Page 290]

APPEARS IN

Avichal Computer Applications [English] Class 10 ICSE
Chapter 4 String Handling
EXERCISES | Q IX. 6. | Page 290
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×