English

Write a program in Java to enter a String/Sentence and display the longest word and the length of the longest word present in the String. Sample Input: "TATA FOOTBALL ACADEMY WILL PLAY AGAINST MOHAN - Computer Applications

Advertisements
Advertisements

Question

Write a program in Java to enter a String/Sentence and display the longest word and the length of the longest word present in the String.

Sample Input: "TATA FOOTBALL ACADEMY WILL PLAY AGAINST MOHAN BAGAN"
Sample output: The longest word: FOOTBALL: The length of the word: 8

Code Writing

Solution

import java.util.*; 
public class SQ5 
{public static void main(String k[]) 
{ String tmp = "", longest = ""; 
int max = 0; 
System.out.println("Enter a sentence"); 
Scanner obj = new Scanner(System.in); 
String s = obj.nextLine() + ' '; // add space
for (int j = 0; J < s.length(); j++)
{
        if (s.charAt(j) != ' ')
        tmp += s.charAt(j);
        else
        {if (tmp.length() > max)
        {max = tmp.length();
        longest = tmp; 
        }
        tmp = ""; // clear tmp
        }} // end of else block, for loop 
System.out.println("The longest word: " + longest); 
System.out.println("Length of the word: " + max);
}}
shaalaa.com
  Is there an error in this question or solution?
Chapter 4: String Handling - EXERCISES [Page 290]

APPEARS IN

Avichal Computer Applications [English] Class 10 ICSE
Chapter 4 String Handling
EXERCISES | Q IX. 5. | Page 290
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×