English

Write a program in Java to input the names of 10 cities in a Single Dimensional Array. Display only those names which begin with a consonant but end with a vowel.  Sample Input: Kolkata, Delhi - Computer Applications

Advertisements
Advertisements

Question

Write a program in Java to input the names of 10 cities in a Single Dimensional Array. Display only those names which begin with a consonant but end with a vowel. 

Sample Input: Kolkata, Delhi, Bengaluru, Jamshedpur, Bokaro, .............
Sample Output: Kolkata
                            Delhi
                            Bengaluru
                            Bokaro
                            .......................
                            .......................

Code Writing

Solution

import java.util.*; 
public class SQ28 { 
public static void main(String h[]){
Scanner scn = new Scanner(System.in);
String c[] = new String[10];
boolean flag = false;
char x, y;

// INPUT LOOP
System.out.println("Enter the city names");
for (int i = 0; i < c.length; i++)
c[i] = scn.nextLine();

System.out.println("\nCities beginning with a consonant and ending with a vowel");
for (int j = 0; j < c.length; j++)
{
    x = c[j].charAt(0); // FIRST CHARACTER
    y =c[j].charAt(c[j].length() - 1); // LAST CHARACTER

    if (! (x == 'a’ || x == 'e' || x == '1' || x == '0' || x == 'u') // NOT operator
&& (y == 'a' || y == 'e' || y == 'i' || y == 'o' || y == 'v'))
    {
    flag = true;
    System.out.println(c[j]);
    }
  }
  if (flag == false)
  System.out.println("Not found");
  }}
shaalaa.com
  Is there an error in this question or solution?
Chapter 4: String Handling - EXERCISES [Page 293]

APPEARS IN

Avichal Computer Applications [English] Class 10 ICSE
Chapter 4 String Handling
EXERCISES | Q IX. 28. | Page 293
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×