English

Write a program to input twenty names in an array. Arrange these names in ascending order of letters, using the bubble sort technique. Sample Input: Rohit, Devesh, Indrani, Shivangi, Himanshu, - Computer Applications

Advertisements
Advertisements

Question

Write a program to input twenty names in an array. Arrange these names in ascending order of letters, using the bubble sort technique.

Sample Input:
Rohit, Devesh, Indrani, Shivangi, Himanshu, Rishi, Piyush, Deepak, Abhishek, Kunal
Sample Output:
Abhishek, Deepak, Devesh, Himanshu, lndrani, Kunal, Piyush, Rishi, Rohit, Shivangi 

Code Writing

Solution

import java.util.*; 
public class SQ27{
public static void main(String args[]){ 
Scanner ob = new Scanner(System.in); 
String a[] = new String[5],temp;

//INPUT LOOP
System.out.println("Enter the twenty names");
for (int i = 0; i < a.length; i++)
a[i] = ob.nextLine();

// REARRANGE
for (int i = 0; i < (a.length - 1); i++)
{for (int j = 0; j < (a.length - 1) - i; j++)
{ if (a[j].compareTo(a[j + 1]) > 0)
  {temp = a[j]; 
  a[j] = a[j + 1];
  a[j + 1] = temp;
}}}

// OUTPUTLOOP 
System.out.println("\n\n The sorted elements in ascending order are:");
for (int k = 0; k < a.length; k++)
System.out.println(a[k]);
}}
shaalaa.com
  Is there an error in this question or solution?
Chapter 4: String Handling - EXERCISES [Page 293]

APPEARS IN

Avichal Computer Applications [English] Class 10 ICSE
Chapter 4 String Handling
EXERCISES | Q IX. 27. | Page 293
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×