English

Write a program to input time in seconds. Display the time after converting them into hours, minutes and seconds. Sample Input: Time in seconds: 5420Sample Output: 1 Hour 30 Minutes 20 Seconds - Computer Applications

Advertisements
Advertisements

Question

Write a program to input time in seconds. Display the time after converting them into hours, minutes and seconds. 

Sample Input: Time in seconds: 5420
Sample Output: 1 Hour 30 Minutes 20 Seconds

Answer in Brief

Solution

import java.util.*;
public class U5_Q4
{public static void main(String ag[])
{Scanner obj = new Scanner(System.in); 
int tsec, hr, min, sec, rem;
tsec = obj.nextlnt();
hr = tsec / 3600;
rem = tsec % 3600; // % gives remainder of tsec / 3600
min = rem / 60; 
sec = rem % 60;
System.out.println{hr + " Hour(s), " + min + " Minute(s), " + sec + " Second(s)");
}}
shaalaa.com
  Is there an error in this question or solution?
Chapter 1.06: Input in Java - EXERCISES [Page 66]

APPEARS IN

Avichal Computer Applications [English] Class 10 ICSE
Chapter 1.06 Input in Java
EXERCISES | Q V. 4. | Page 66
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×