English

Write a program to input two unequal numbers. Display the numbers after swapping their values in the variables without using a third variable. Sample Input: a = 76, b = 65Sample Output: a = 65, b = 76 - Computer Applications

Advertisements
Advertisements

Question

Write a program to input two unequal numbers. Display the numbers after swapping their values in the variables without using a third variable. 

Sample Input: a = 76, b = 65
Sample Output: a = 65, b = 76

Answer in Brief

Solution

import java.util.*;
public class U5_Q6
{public static void main(String args[]) 
{Scanner in = new Scanner(System.in)
int a, b; 
System.out.println("Enter the two numbers"); 
a = in.nextlnt(); 
b = in.nextlnt();
System.out.println("Before Swapping \n a = " + a + " b = " + b)
a = a + b;
b = a − b; 
a = a − b; 
System.out.println("After Swapping \n a = " + a + " b = " + b); 
}}
shaalaa.com
  Is there an error in this question or solution?
Chapter 1.06: Input in Java - EXERCISES [Page 67]

APPEARS IN

Avichal Computer Applications [English] Class 10 ICSE
Chapter 1.06 Input in Java
EXERCISES | Q V. 6. | Page 67
Share
Notifications

Englishहिंदीमराठी


      Forgot password?
Use app×